Bridge domains on Cisco IOS-XE

I was recently tasked to set up a layer 2 cross connect to another city from a HQ to another branch. The ISP gave 2 interconnects on each end that connect to two physical routers on their side but provide the same layer 2 service on a vlan. We only had 1 cisco ASR router on either end. My idea was to bridge the two interfaces into a single bridge and switch across to the other city. Simple task, but I did not realize that the routers i had to work with was IOS-XE. I have not worked on IOS-XE yet.

Bridge domain layout

 

The configuration for this scenario used to be something like this:

bridge 1 protocol ieee
bridge 1 route ip
!
interface GigabitEthernet0/1.999
encapsulation dot1q 999
bridge-group 1
!
interface GigabitEthernet0/2.999
encapsulation dot1q 999
bridge-group 1
!
interface BVI 1
ip address 1.1.1.1 255.255.255.252
!

This configuration has now changed. Took me almost an hour to figure it out. Configuration for bridge domain and sub interfaces on cisco ASR running ios-xe:

bridge irb

!
interface Gig0/1
no ip address
negotiation auto
service instance 999 ethernet
encapsulation dot1q 999
bridge-domain 999
!
interface Gig0/2
no ip address
negotiation auto
service instance 999 ethernet
encapsulation dot1q 999
bridge-domain 999
!
interface BDI1
ip address 1.1.1.1 255.255.255.252

AS you can see, its the same idea and you get the same result, its just put together differently.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>